Data Refresh Issue

Incident Report for learningpool

Update

We are continuing to investigate this issue
Posted Mar 12, 2026 - 12:00 UTC

Investigating

We are aware of an issue currently impacting US instances of Analytics resulting in data not being displayed/up-to-date. Our team is actively investigating and working to resolve the issue.
Posted Mar 12, 2026 - 10:38 UTC
This incident affects: Analytics.